Thanks Thanks:  8
Likes Likes:  23
Results 1 to 7 of 7

Thread: 2008 RAM 2500 6.7L Cummins - Bad Vibration/Shake?

  1. Top Of Page | #1
    chase58's Avatar

    User Info Menu

    2008 RAM 2500 6.7L Cummins - Bad Vibration/Shake?

    08 6.7L with G56, DRD tuned.

    Cross-country trip SOON.

    It suddenly developed bad vibration.

    It's worst at idle while sitting still in neutral but there through all rpm ranges.

    There is no correlation between motion and speed.

    It seems worse under a light load but goes away under a heavy load and higher boost levels.

    I can feel it when the motor turns over before it fires, and the shake at shutdown is highly exaggerated.

    The truck seems to run and sound completely normal other than a slight drone in the exhaust note that stated simultaneously.

    Things I've checked:
    Valve Lash
    Motor Mounts
    Harmonic Balancer

    I borrowed a matco diagnostic tool and did an injector kill test.

    Everything seemed normal there, but all ran a fuel system check which failed in several steps but gave no explanation on what exactly was being tested or why those steps failed.

    I am lost on what else to check; any idea or insight is greatly appreciated.

    I have a trip from SC to TX in a few days, and I dont want to grenade anything or be left on the side of the road.


  2. Thanks IGOTACUMMINS thanked for this post
  3. Top Of Page | #2
    DANG IT'S COLD! AK Bob's Avatar

    User Info Menu

    2008 RAM 2500 6.7L Cummins - Bad Vibration/Shake?

    Odd, it sounds like you have already checked the apparent suspects; motor mounts would have been my first guess.

    Have you noticed any correlation between the vibration and exhaust pressure pulses at the tailpipe?

    2014 RAM 3500 (Aisin) 3.73 4X4 Limited Crew Cab Long Bed DRW. Oil Bypass Filter, Fuel Filtration Kit, Cold Air Intake and 50 Gallon Aux Fuel Tank.

  4. Thanks IGOTACUMMINS thanked for this post
    Likes watersupply189, Corkey, IGOTACUMMINS liked this post
  5. Top Of Page | #3
    chase58's Avatar

    User Info Menu

    2008 RAM 2500 6.7L Cummins - Bad Vibration/Shake?

    Yes, in the sense that it corresponds with the rhythm of the motor.


  6. Thanks IGOTACUMMINS thanked for this post
    Likes watersupply189, Corkey, IGOTACUMMINS liked this post
  7. Top Of Page | #4
    DANG IT'S COLD! AK Bob's Avatar

    User Info Menu

    2008 RAM 2500 6.7L Cummins - Bad Vibration/Shake?

    Not up to speed on the Gen 3 G56, but wondering if you have the dual mass flywheel?

    2014 RAM 3500 (Aisin) 3.73 4X4 Limited Crew Cab Long Bed DRW. Oil Bypass Filter, Fuel Filtration Kit, Cold Air Intake and 50 Gallon Aux Fuel Tank.

  8. Thanks IGOTACUMMINS thanked for this post
    Likes watersupply189, Corkey, IGOTACUMMINS liked this post
  9. Top Of Page | #5
    MOD watersupply189's Avatar

    User Info Menu

    2008 RAM 2500 6.7L Cummins - Bad Vibration/Shake?

    It kind of makes me think it has something to do with your clutch or your flywheel being a little loose or warped.


    2016 Ram Laramie 3500, G56, 6.7, CC, 4x4

    2016 RAM 3500 4x4 Laramie Crew Cab
    Cummins,G56, Rough Country level, Morimoto LED fog lights, LED headlights, Lund Attitude Steps w/Line-X, DRL's Activated, 35x11.50R18 Falken Wildpeak, Fuel Vapor Wheels Matte Black w/Dark Tint, A.R.E. Truck cap

    2023- Jeep Wrangler Rubicon w/extreme Recon 35” tire package

    Past- 2015 Jeep Grand Cherokee Limited 4x4
    Past- 2019 Dodge Charger 392 R/T Scatpack Plus
    Past - 2014 RAM 1500 4x4 Lone-Star Eco Diesel

  10. Thanks IGOTACUMMINS thanked for this post
    Likes AK Bob, Corkey, IGOTACUMMINS liked this post
  11. Top Of Page | #6
    chase58's Avatar

    User Info Menu

    2008 RAM 2500 6.7L Cummins - Bad Vibration/Shake?

    No, I should've included that in my original post, but it's a solid flywheel with a Valair dual ceramic clutch.


  12. Thanks watersupply189, IGOTACUMMINS thanked for this post
  13. Top Of Page | #7
    Corkey's Avatar

    User Info Menu

    2008 RAM 2500 6.7L Cummins - Bad Vibration/Shake?

    When has the fuel filter been replaced?

    Yes, with a plugged filter, a bad vibration clicks in my head.

    If what you have checked tallies out, what I would suggest, is to look at the fueling.

    CP3 A\D, injector rates, filter, and or plugged lines.

    Have you been running any fuel additives?

    With the scan tool, no codes have tripped.

    II 60HP STICKS, II 33% CP3, II S464 2ND GEN SWAP, FASS 165 TITANIUM SIGNATURE SERIES, AFE INTAKE HORN, S&B FILTER, 5" TURBO BACK, ALPHAREX HEAD LIGHTS, 38X13.5X20 RAZOR M/T, MOTO METAL RIMS, 6" LA LIFT KIT, COMPLET MM3 KIT, BUILT TRANSMISSION, 6 BOLT REDHEAD STEERING BOX

  14. Thanks IGOTACUMMINS thanked for this post
    Likes watersupply189, AK Bob, IGOTACUMMINS liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •