Thanks Thanks:  1
Likes Likes:  7
Results 1 to 3 of 3

Thread: 2012 RAM 2500 Transmission Help/Suggestions

  1. Top Of Page | #1

    User Info Menu

    2012 RAM 2500 Transmission Help/Suggestions

    Hey all, 2012 2500 68RFE.

    H&S tuned and deleted with transmission unlock as well.

    37s with 3.73 (at time of issue) gearing... 4.10s on the way.

    A while back, I would get an intermittent p0770 shift solenoid code which would put the truck in limp mode.

    Maybe once every two weeks.

    It’s progressively gotten worse to about once a drive.

    Also saw a fuel rail pressure sensor and transmission fluid pressure sensor code pop up once.

    It was recommended to replace the TIPM as it seemed like an electrical issue more than a trans issue.

    I replaced TIPM, and the issue persisted.

    I took my truck into Everett’s Transmission in FL, and he now thinks it’s a transmission problem.

    Rather than rebuild the trans, he wants to have me buy a built trans from someone.

    Not sure how far down the rabbit hole I’ll end up going. My budget is totally blasted now, so do I put something in to get by?

    Is it worth putting in a built transmission and dip further into my emergency fund?

    If I get a built trans, do I need to get a new tuner to replace the dated H&S? Etc, etc.

    I don’t tow a lot, but it is a consideration.

    I also just ordered Yukon 4.10s so that the gearing will be in a better place.

    I really appreciate any help you can provide.
    Landon


  2. Thanks IGOTACUMMINS thanked for this post
    Likes watersupply189, IGOTACUMMINS, AK Bob liked this post
  3. Top Of Page | #2
    Big Daddy IGOTACUMMINS's Avatar

    User Info Menu

    Re: 2012 RAM 2500 Transmission Help/Suggestions

    The problem is H&S tuning has been dead for years.

    God bless,
    igotacummins

    "The grass is greener where you water it"


  4. Likes watersupply189, AK Bob, SyN liked this post
  5. Top Of Page | #3

    User Info Menu

    Re: 2012 RAM 2500 Transmission Help/Suggestions

    Quote Originally Posted by IGOTACUMMINS View Post
    The problem is H&S tuning has been dead for years.

    God bless,
    igotacummins
    Think the tuner would cause the P0770 code?


    Sent from my iPhone using Tapatalk


  6. Likes watersupply189 liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •