Thanks Thanks:  3
Likes Likes:  10
Results 1 to 7 of 7

Thread: ABS Control Module

  1. Top Of Page | #1
    Basic Member wbayne's Avatar

    User Info Menu

    ABS Control Module

    Anyone have any experience replacing these?

    Dealer says part is on nationwide backorder and wont even resume production till August 5th.

    Looks like local parts stores can get aftermarket but concerned about reliability.


    Sent from my iPhone using Tapatalk


  2. Likes watersupply189 liked this post
  3. Top Of Page | #2
    More Powa! RATLIN'HP's Avatar

    User Info Menu

    Re: ABS Control Module

    No experience but I'd think to install one would be as simple as unplugging, remove, install, and plug in.

    Just not sure if it would have the calibration needed to match, and if that would end up being a dealer thing anyway?

    Sent from my SM-A505U using Tapatalk

    2015 Black Laramie CCSB 3500 SRW. Thuren Leveled With Fox 2.0 Shocks. Ride Rite Rear Air Bags With Wireless Airlift Onboard Air. 35" Toyos. All The Options Minus The Soot Cookers. RaceMe Ultra.

  4. Likes watersupply189 liked this post
  5. Top Of Page | #3
    Chrisn162001's Avatar

    User Info Menu

    Re: ABS Control Module

    What year module truck?

    You need the module or the hydraulic control unit? What code are you getting?

    I’m a dealer tech we have been replacing the hydraulic control units like crazy.

    The modules don’t really go bad that often.


    Sent from my iPhone using Tapatalk


  6. Likes watersupply189 liked this post
  7. Top Of Page | #4
    Basic Member wbayne's Avatar

    User Info Menu

    Re: ABS Control Module

    Its an 11.

    Apparently the module came unhooked or loose and got wet causing some corrosion.

    Lost connection with ABS control module and I can't remember code number.


    Sent from my iPhone using Tapatalk


  8. Likes Chrisn162001, watersupply189 liked this post
  9. Top Of Page | #5

    User Info Menu

    Re: ABS Control Module


  10. Top Of Page | #6

    User Info Menu

    Re: ABS Control Module

    Quote Originally Posted by Chrisn162001 View Post
    What year module truck?

    You need the module or the hydraulic control unit? What code are you getting?

    I’m a dealer tech we have been replacing the hydraulic control units like crazy.

    The modules don’t really go bad that often.


    Sent from my iPhone using Tapatalk
    Hi Chris. I drive a 2018 Laramie 2500.

    Came to the forum looking for info on the ABS system and saw your post that you’re a tech.

    Last night, I’m driving home from dinner and I punched it to pass someone on a two lane highway.

    Once I got past them, I let off the throttle and my exhaust brake kicked in.

    Once I got near my cruising speed, I set the cruise control and almost immediately my ABS and traction control system lights started coming on and going off intermittently.

    The lights would not allow my cruise control to continue working and they just kept coming on and going off in random patterns.

    I was also getting two messages on screen. “Service ABS system” and “ Service electronic braking system”

    I pulled over and turned the truck off for a few minutes.

    When I restarted, they flickered on and off a couple times and then stayed off. I started driving home, with cruise control set for about 2-3 miles with no issues.

    Then, as I’m pulling into the driveway, they flickered on and off again a couple times.

    Obviously, I know I need to take it to a dealer.

    Luckily the truck is still under warranty.

    My question is, is this problem going to be perpetual?

    I’ve read elsewhere on the internet about this exact issue and it seems a lot of people are having problems getting the issue to go away permanently.

    Has Chrysler figured out what’s causing this yet and developed a reliable fix?

    I have attached a link to a video my wife took. You should be able to click on it and watch it. I appreciate any knowledge you can share.

    https://www.vzmessages.com/vl/bf88a7...d56d0a01154826


  11. Thanks watersupply189 thanked for this post
    Likes watersupply189, AK Bob liked this post
  12. Top Of Page | #7
    Chrisn162001's Avatar

    User Info Menu

    ABS Control Module

    Yeah sounds like your hcu went bad.

    We just replace them. I think it’s a updated part number but I’d have to check to be sure.

    I haven’t had one come back after replacing hcu. Replaced mine at 18k been good for last 30k


    Sent from my iPhone using Tapatalk


  13. Thanks watersupply189, VolRam thanked for this post
    Likes watersupply189, AK Bob, VolRam liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •