Join us as a Lifetime Platinum Member today!

Thanks Thanks:  0
Likes Likes:  11
Results 1 to 9 of 9

Thread: WIF Light HELP!!

  1. Top Of Page | #1
    Johnsondoie's Avatar

    User Info Menu

    WIF Light HELP!!

    So I deleted my truck couple weeks ago (2015 3500 DRW) since then I’ve had the wif light on. Changed filters....still on. So drained the tank changed filters again and wif both sensors....light still on. Now I get a dtc code on MM3. P238D no description found! I’ve check all the wiring up under truck to make sure I didn’t cut any wires. Can’t come up with anything. Anyone have any ideas? Or had same problem?


  2. Likes AK Bob, timshooter40, walla2k5 liked this post
  3. Top Of Page | #2
    DDP's Avatar

    User Info Menu

    Re: WIF Light HELP!!

    Quote Originally Posted by Johnsondoie View Post
    So I deleted my truck couple weeks ago (2015 3500 DRW) since then I’ve had the wif light on. Changed filters....still on. So drained the tank changed filters again and wif both sensors....light still on. Now I get a dtc code on MM3. P238D no description found! I’ve check all the wiring up under truck to make sure I didn’t cut any wires. Can’t come up with anything. Anyone have any ideas? Or had same problem?
    Should mean that the water in fuel sensor b circuit high. Sometimes it's hard to see but check all the wires again and the wires right where it connects to the sensor. Check all the wire coating as well as sometimes it rubs a slight tear in it causing this issue. Could just need to replace the sensor as well.

    Matthew 6:9-13, 2 Corinthians 5:20
    See what we are up to on:
    FACEBOOK
    INSTAGRAM
    Or Email us at:
    Clayton@DudesDieselPerformance.com

  4. Likes AK Bob, timshooter40, walla2k5 liked this post
  5. Top Of Page | #3
    Old ... But Still Here ! AnOldBiker's Avatar

    User Info Menu

    Re: WIF Light HELP!!

    Do you have a dual filter system?
    Just the original fuel filter bowl?
    What set up?

    Not sure of the '15s stock setup, but was there something in the bowl that could set the wif sensor off? And agree with check the sensor and wires again.



    Jim


    2006 ~ 2500HD, Big Horn Edition, 5.9, 4x4, Q/Cab, 48RE, L/B, 3.73, S&B CAI & Snout, ProFlo 5" S/S exhaust, Smarty Touch, Oil ByPass Kit, 60 gal main tank, 110 gallon in-bed tank, XX-Fuel Filter System, Coolant Bypass Kit, Mag-Hytec front & rear end covers and trans pan, 285 x 70 x 17

    "Freedom is never more than one generation away from extinction. We didn't pass it to our children in the bloodstream. It must be fought for, protected, and handed on for them to do the same, or one day we will spend our sunset years telling our children and our children’s children what it was once like in the United States, where men 'were' free." ~ Ronald Regan

  6. Likes walla2k5 liked this post
  7. Top Of Page | #4
    walla2k5's Avatar

    User Info Menu

    Re: WIF Light HELP!!

    I fought a similar problem with my 2013.

    I replaced both sensors and haven't had a problem since.
    @Geno's Garage usually has them in stock. Lots of dielectric grease in the pigtail, for piece of mind.

    2013 Ram 2500 Big Horn 4x4 G56 CCLB 6.7, MM3 Tuned by Double R Diesel, Flo-Pro 4" Exhaust, Deviant Race Parts, ARP Head Studs, Valair Quiet Dual Disc Clutch, 2" Level, Hell Bent Steel Steering Box Brace, Bilstein 5100 shocks, Thuren track bar, Air-Lift 5000, Falken 285/75-17 AT3W.

  8. Likes cumminsdieselfreak liked this post
  9. Top Of Page | #5
    Johnsondoie's Avatar

    User Info Menu

    Re: WIF Light HELP!!

    I’m gonna get back under it after work today and looked at the wires again.

    I have already replaced both sensors.

    Yes sir It has the water separator on the rear cross member and a fuel bowl on feed line on side of the block also.


  10. Top Of Page | #6
    cumminsdieselfreak's Avatar

    User Info Menu

    Re: WIF Light HELP!!

    Quote Originally Posted by Johnsondoie View Post
    I’m gonna get back under it after work today and looked at the wires again.

    I have already replaced both sensors.

    Yes sir It has the water separator on the rear cross member and a fuel bowl on feed line on side of the block also.
    So you drained the fuel bowl on the block, correct? Did you clear the codes with your MM3 after you replaced the sensors?

    2018 Ram 2500 4x4 G56
    Romans 10:13

    See what we are up to on:
    FACEBOOK | INSTAGRAM
    Or Email me at:
    Joe@DudesDieselPerformance.com
    https://dudesdieselperformance.com/

  11. Top Of Page | #7
    Johnsondoie's Avatar

    User Info Menu

    Re: WIF Light HELP!!

    Yea I Drained the fuel bowl replaced both filters also both sensors....there was a quarter tank of fuel (was worried it actually had a lot of water in it) so we pumped it out.

    Cleared the code and Light still on. Got under there last night looked and looked the wiring harness over its in great shape.

    Used electrical cleaner and electrical grease on the plug, cleared the code and light came right back on.

    I’m lost!!!!


  12. Top Of Page | #8
    Johnsondoie's Avatar

    User Info Menu

    Re: WIF Light HELP!!

    No duel filter setup...completely factory.


  13. Top Of Page | #9
    Johnsondoie's Avatar

    User Info Menu

    Re: WIF Light HELP!!

    SUCCESS!!!!

    So got u see the truck earlier.

    Spray the WIF plug with dielectric cleaner like crazy.

    Light still on.

    So I got some go go gadget picks.

    Unhooked the plug and went full

    Operational surgery mode on the truck side of the plug.....and there !!IT!! was a grain of sand.
    Got it worked out. And light off!!!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •