Thanks Thanks:  7
Likes Likes:  43
Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Intake Horn Banks A "Hole"

  1. Top Of Page | #11
    flanagan's Avatar

    User Info Menu

    I am pretty sure it will throw code since it doesn't draw as much amps as the factory one does I wonder if ray can tweak the tuning to fix the engine code if it comes on

    Sent from my SM-G973U using Tapatalk


  2. Thanks niteghost thanked for this post
    Likes watersupply189, Murph, timshooter40 liked this post
  3. Top Of Page | #12
    Murph's Avatar

    User Info Menu

    I like it and am curious also.... Waiting for your furtherance.

    BY THE WAY I feel the same about GB.


  4. Likes timshooter40, watersupply189 liked this post
  5. Top Of Page | #13
    Old & Grumpy! Polaraco's Avatar

    User Info Menu

    Really?

    I'd like to see that used in Alaska.

    There isn't enough surface to heat the air enough.

    Banks. . . . Ugh


    2003- 3500 RWD Automatic.
    S & B intake, BD Intercooler, Pusher Air Horn, MM3 Double R Tuning, Turbo Timer, electric Flex-a-lite fans, FASS 95,
    50 HP tips, upgrade to 351 turbo, 3.42 gears, Twin air compressors, air bags, Remote dual oil filters, Hellwig sway bar, Front Winch. Home made Fuel Heater, BD Exhaust brake with Torque Lock. Tons of TLC

  6. Likes AK Bob, watersupply189 liked this post
  7. Top Of Page | #14
    flanagan's Avatar

    User Info Menu

    So what are you running with your pusher intake horn?

    I was so close and almost went that route.

    Sent from my SM-G973U using Tapatalk


  8. Likes watersupply189 liked this post
  9. Top Of Page | #15
    flanagan's Avatar

    User Info Menu

    I guess I was being stupid and thought it was better than nothing.

    Sent from my SM-G973U using Tapatalk


  10. Likes watersupply189 liked this post
  11. Top Of Page | #16
    flanagan's Avatar

    User Info Menu

    Quote Originally Posted by flanagan View Post
    I guess I was being stupid and thought it was better than nothing.

    Sent from my SM-G973U using Tapatalk
    The Heater in the intake horn works flawlessly no codes.



    Sent from my SM-G973U using Tapatalk


  12. Thanks watersupply189, Jaxonsram thanked for this post
    Likes watersupply189, david3gen, Jaxonsram liked this post
  13. Top Of Page | #17
    TexNeck's Avatar

    User Info Menu

    Quote Originally Posted by flanagan View Post
    The Heater in the intake horn works flawlessly no codes.

    https://uploads.tapatalk-cdn.com/202...b0d2eebc5f.jpg

    Sent from my SM-G973U using Tapatalk
    Where is your CCV run to?

    I see this hose turned back behind the valve cover.

    2013 Ram 2500
    John 3:16 - Philippians 4:13

    See what we are up to on:
    FACEBOOK | INSTAGRAM
    Or Email me at:
    Mike@DudesDieselPerformance.com
    https://dudesdieselperformance.com/



  14. Likes watersupply189, SyN liked this post
  15. Top Of Page | #18
    Old & Grumpy! Polaraco's Avatar

    User Info Menu

    Re: Intake Horn Banks A "Hole"

    Quote Originally Posted by flanagan View Post
    Just wondering if I can put a heater in a aftermarket intake horn.

    I do not like the guy but,I am looking at the monster ram and grid heater delete.

    My heater is throwing cel code.

    Sent from my SM-G950U1 using Tapatalk
    Shippy Engineering was the original of that concept and had the best flow.

    Check with @DRD


    2003- 3500 RWD Automatic.
    S & B intake, BD Intercooler, Pusher Air Horn, MM3 Double R Tuning, Turbo Timer, electric Flex-a-lite fans, FASS 95,
    50 HP tips, upgrade to 351 turbo, 3.42 gears, Twin air compressors, air bags, Remote dual oil filters, Hellwig sway bar, Front Winch. Home made Fuel Heater, BD Exhaust brake with Torque Lock. Tons of TLC

  16. Likes watersupply189, SyN liked this post
  17. Top Of Page | #19
    flanagan's Avatar

    User Info Menu

    Re: Intake Horn Banks A "Hole"

    Quote Originally Posted by TexNeck View Post
    Where is your CCV run to?

    I see this hose turned back behind the valve cover.
    I ran it down to the frame on the driver's side with a filter on it.

    Sent from my SM-G973U using Tapatalk


  18. Likes watersupply189, SyN liked this post
Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •