Truck Wurx

Thanks Thanks:  1
Likes Likes:  11
Results 1 to 6 of 6

Thread: New to tuner need help

  1. Top Of Page | #1
    Basic Member Cam237's Avatar

    User Info Menu

    New to tuner need help

    I have a 2016 Dodge 2500 Laramie with 305/55/20 with the raceme tuner in it

    I haul roughly 15k pounds maybe more. I run my tuner on stock vgt and 30hp. Issue I'm having is that i can't keep my speed and in 5th gear my turbo spools very easily. Rpms don't move but turbo is spiking to 35psi. I've tried locking 5th RS run 2k but can't keep my speed.


  2. Thanks watersupply189 thanked for this post
    Likes david3gen, watersupply189, AnOldBiker liked this post
  3. Top Of Page | #2
    david3gen's Avatar

    User Info Menu

    Re: New to tuner need help

    Welcome @Cam237


    Sent from my iPhone using Tapatalk

    2006 dodge ram 2500 laramie crew cab 5.9 cummins. 10x20 et-24 fuel offroad with 275.60r20 tires. bully dog gt tuner. 48re ATS built tranny triple disc converter ATS oilpan and transgo quick shifter. 4" turbo back exhaust. brembo discs and pads

  4. Likes watersupply189, AnOldBiker liked this post
  5. Top Of Page | #3
    Here to protect and serve! watersupply189's Avatar

    User Info Menu

    Re: New to tuner need help

    Quote Originally Posted by Cam237 View Post
    I have a 2016 Dodge 2500 Laramie with 305/55/20 with the raceme tuner in it

    I haul roughly 15k pounds maybe more. I run my tuner on stock vgt and 30hp. Issue I'm having is that i can't keep my speed and in 5th gear my turbo spools very easily. Rpms don't move but turbo is spiking to 35psi. I've tried locking 5th RS run 2k but can't keep my speed.
    Welcome friend! I know we have experts on here that can answer your question.


    2016 Ram Laramie 3500, G56, 6.7, MM3 by Double R Diesel, Rough Country Leveling, 35x12.50 Nitto G2, HID headlights and fogs plus many many other add ons.....

    2016 Ram 3500 4x4 Laramie Crew Cab
    Cummins, G56, Rough Country Leveling, 35W HID fog lights,35W HID headlights, Lund Attitude Step Bars Sprayed Line-X, Window Vent Visors from EGR, LED Cargo, tag and backup lights, Windows Tinted, DRL's Activated, 35x12.50 18 Nitto Terra Grappler G2, Fuel Vapor Wheels Matte Black w/ Dark Tint, A.R.E. topper, MM3 Tuned by Double R Diesel
    2015 Jeep Grand Cherokee Limited 4x4
    Past- 2014 Ram 1500 4x4 Lone-Star Eco Diesel

  6. Likes AnOldBiker, david3gen liked this post
  7. Top Of Page | #4
    Old ... But Still Here ! AnOldBiker's Avatar

    User Info Menu

    Re: New to tuner need help



    Jim


    2006 ~ 2500HD, Big Horn Edition, 5.9, 4x4, Q/Cab, 48RE, L/B, 3.73, S&B CAI & Snout, ProFlo 5" S/S exhaust, Smarty Touch, Oil ByPass Kit, 60 gal main tank, 110 gallon in-bed tank, XX-Fuel System, Coolant Bypass Kit, Mag-Hytec front & rear end covers and trans pan, 285 x 70 x 17

    "Freedom is never more than one generation away from extinction. We didn't pass it to our children in the bloodstream. It must be fought for, protected, and handed on for them to do the same, or one day we will spend our sunset years telling our children and our children’s children what it was once like in the United States, where men 'were' free." ~ Ronald Regan

  8. Likes watersupply189, david3gen liked this post
  9. Top Of Page | #5
    Basic Member Bobtipton's Avatar

    User Info Menu

    Re: New to tuner need help

    Quote Originally Posted by Cam237 View Post
    I have a 2016 Dodge 2500 Laramie with 305/55/20 with the raceme tuner in it

    I haul roughly 15k pounds maybe more. I run my tuner on stock vgt and 30hp. Issue I'm having is that i can't keep my speed and in 5th gear my turbo spools very easily. Rpms don't move but turbo is spiking to 35psi. I've tried locking 5th RS run 2k but can't keep my speed.
    I’m pulling about the same weight (fifth wheel camper) with a 2010 CC dually 3.73 rear end with a RaceMe Ultra tuner on box tunes. I run plain stock (no added hp) and all other settings on default. I stay locked in fifth gear and run at 60-65 mph. Holds that speed well unless I pull a fairly steep grade. I just roll with it and monitor EGTs. I find that if I slow to 50 mph going up a grade, rpms are too low so I downshift to fourth.

    Today we pulled from Del Rio, TX, to Honda, TX. Pretty stiff headwind (20 mph) and some short grades on US-90. On the flats in fifth gear with the headwind, I could easily maintain 60 mph with EGTs around 850-860 degrees. Some of the lesser grades it would slow to 55 mph by the time I reached the top, and EGTs never went over 1000. Never at any point went over 16 pounds of boost.

    That being said, I really don’t know what the issue might be but I post this for comparison. Maybe double-check your settings? Like I said, mine is set to stock with everything else (turbo spool, timing, fuel rail settings, etc.) all on default.

    Bob


    Sent from my iPad using Tapatalk


  10. Likes watersupply189 liked this post
  11. Top Of Page | #6
    Basic Member Cam237's Avatar

    User Info Menu

    Re: New to tuner need help

    I'll give that a try later today when i hook up. I'm just used to my 2012 Cummins with the h&s mini Maxx and i could run 65-70 with no issue and turbo would never spool up like my 2016 does.


  12. Likes watersupply189 liked this post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •