Draconian Diesel

Thanks Thanks:  9
Likes Likes:  54
Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 44

Thread: Please help! Truck wont start after EGR and throttle valve deletes.

  1. Top Of Page | #31
    Basic Member Coal Rollin's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    Quote Originally Posted by BKinky View Post
    It's a 2015 Ram 2500 Cummins. The MM3 tuner will unlock the ECM and flash it without the need for anything else.
    Hmmm then I don't know.

    Does anyone have a flash drive of tunes that have been verified that you can borrow?

    Sent from my SM-N960U using Tapatalk


  2. Likes watersupply189 liked this post
  3. Top Of Page | #32
    Big Daddy! IGOTACUMMINS's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    WAIT!

    If you flash it back to stock does this happen?

    Join as a Lifetime Platinum Member Today

    Without you, we cease to exist. Without your support, we stop growing. Without your involvement, we remain at a standstill.
    Thank you for your faithfulness to our organization and your creative ideas and support.




  4. Top Of Page | #33
    Basic Member BKinky's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    Quote Originally Posted by Coal Rollin View Post
    Hmmm then I don't know.

    Does anyone have a flash drive of tunes that have been verified that you can borrow?

    Sent from my SM-N960U using Tapatalk
    I have a couple buddies that have 2012's 2500's but those are 3rd gens and I don't know if that would work or not. I might check into that. Thanks.


    Sent from my iPad using Tapatalk


  5. Likes Coal Rollin, watersupply189 liked this post
  6. Top Of Page | #34
    Basic Member BKinky's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    Quote Originally Posted by IGOTACUMMINS View Post
    WAIT!

    If you flash it back to stock does this happen?

    Join as a Lifetime Platinum Member Today
    If I flash it back to stock it wouldn't start for the last 6 days. But after installing the latest tune from Anarchy it will start about half the time. After a short drive and trying to clear the crankshaft position sensor code mentioned above, it's constantly giving me 2 codes 1 for the crankshaft and 1 for the throttle valve controller.

    I posted a link to a separate thread above. It pretty describes my exact situation. Or just look up code P0335.




    Sent from my iPad using Tapatalk


  7. Likes watersupply189 liked this post
  8. Top Of Page | #35
    Basic Member BKinky's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    Here's the codes.

    Sent from my SM-N950U using Tapatalk


  9. Likes watersupply189 liked this post
  10. Top Of Page | #36
    Basic Member Coal Rollin's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    Hmm. Do toy have a pedal commander? Sounds alot like a tune problem. They've got something screwy somewhere.

    Sent from my SM-N960U using Tapatalk


  11. Likes watersupply189 liked this post
  12. Top Of Page | #37
    RamHunter18's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    Does sound like symptoms of a crank sensor dropping signal. The throttle control is pretty common to see after a fresh flash for a cycle or two on some trucks. Check your crank sensor connection. Driver side at the balancer. Make sure your exhaust pressure sensor plug is fully seated and clicked in


  13. Thanks BKinky thanked for this post
    Likes watersupply189 liked this post
  14. Top Of Page | #38
    Dwelsh's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    Quote Originally Posted by BKinky View Post
    If I flash it back to stock it wouldn't start for the last 6 days. But after installing the latest tune from Anarchy it will start about half the time. After a short drive and trying to clear the crankshaft position sensor code mentioned above, it's constantly giving me 2 codes 1 for the crankshaft and 1 for the throttle valve controller.

    I posted a link to a separate thread above. It pretty describes my exact situation. Or just look up code P0335.




    Sent from my iPad using Tapatalk
    Just for giggles. See if you can get an rpm reading when turning the truck over with like a scanner or something. I dont believe the mm3 will do it as it powers down when cranking. Ive seen a whole lot of coinsidences but it dont sound right. I know people have given you a whole lot of try to's so if ya dont wanna try it i feel ya. But what i would do is plug everything back up as stated. But then clear all the codes and start it. See what happens. Could be a case where something isnt right with the tunes. And its not seeing anything from the throttle valve so its throwing a crank position code to not allow the truck to start. Just a thought.
    I didnt pay attention when i did my truck . Its also possible coolant landed just right on the crank sensor and it didnt like it lol countless possibilities.

    2016 2500 slt. 4x4. 20x10 moto metal 970s on 305-55-20. Fully deleted with mm3. 5 inch tbe.

  15. Likes watersupply189, RamHunter18 liked this post
  16. Top Of Page | #39
    Basic Member BKinky's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    Quote Originally Posted by Dwelsh View Post
    Just for giggles. See if you can get an rpm reading when turning the truck over with like a scanner or something. I dont believe the mm3 will do it as it powers down when cranking. Ive seen a whole lot of coinsidences but it dont sound right. I know people have given you a whole lot of try to's so if ya dont wanna try it i feel ya. But what i would do is plug everything back up as stated. But then clear all the codes and start it. See what happens. Could be a case where something isnt right with the tunes. And its not seeing anything from the throttle valve so its throwing a crank position code to not allow the truck to start. Just a thought.
    I didnt pay attention when i did my truck . Its also possible coolant landed just right on the crank sensor and it didnt like it lol countless possibilities.
    I'm willing to try anything and I am thankful for everyone's help! I'll try to figure out how to get an rpm reading while starting. I did try plugging everything back in but not sure if I cleared the codes before trying to start it. I'll try that again. I checked the connection for the crankshaft position sensor and it didn't have any coolant on it. My next steps are to reinstall the throttle valve and/or replace the crankshaft position sensor.

    Sent from my SM-N950U using Tapatalk


  17. Likes watersupply189, Dwelsh, RamHunter18 liked this post
  18. Top Of Page | #40
    Basic Member BKinky's Avatar

    User Info Menu

    Re: Please help! Truck wont start after EGR and throttle valve deletes.

    PROBLEM FIXED!!!
    After finding and fixing my truck I now know exactly what happened. While removing the crossover egr tube I didn't realize that I had dropped one of the metal o-ring caskets. It apparently fell onto the teeth of harmonic balancer. After starting my truck it ran perfectly the first time but would not start again. I installed the new crankshaft position sensor and it fired up and is running perfectly! Thank the lord! I have spend a number of hours tracking this problem down but more importantly I want to think Caleb and the rest of the staff Anarchy Diesel for genuinely working hard to help me! They sent me 3 different custom tune packages and even pulled sensors off one of their personal trucks to mimic my issues. I also want to thank all of you on this forum for all the great ideas and suggestions! This is truly a valuable resource to have!

    Sent from my SM-N950U using Tapatalk


  19. Thanks watersupply189 thanked for this post
Page 4 of 5 FirstFirst ... 2345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •